StarTech.com

4 Port PCI Express Low Profile High Speed USB Card

Add 4 USB 2.0 ports to your low profile/small form factor computer through a PCI Express expansion slot

Product ID: PEXUSB4DP

  • 3 external and 1 internal USB 2.0 port
  • High Speed USB 2.0 compliant, with transfer rates up to 480Mbps
  • Backward compatible with USB 1.0/1.1 devices
View More
  • Provide up to 500mA of power per port with dedicated power input
  • Plug-and-Play compatible
  • Includes a full profile installation bracket
47,99 € EUR exc VAT
59,99 € EUR inc VAT
In stock with partners:
Where To Buy

Technical Specifications

Warranty Information
Warranty 2 Years
Hardware
Bus Type PCI Express
Card Type Low Profile (SP bracket incl.)
Chipset ID VIA/VLI - VT6212
Industry Standards PCI Express One Lane 2.5Gb/s
Interface USB 2.0
Ports 4
Performance
Type and Rate USB 2.0 - 480 Mbit/s
Connector(s)
Connector Type(s) 1 - PCI Express x1 Male
External Ports 3 - USB Type-A (4 pin) USB 2.0 Female
Internal Ports 1 - SP4 (4 pin, Small Drive Power) Male
1 - USB Type-A (4 pin) USB 2.0 Female
Software
OS Compatibility Windows® 2000, XP, Vista, 7, 8, 8.1, 10
Windows Server® 2003, 2008 R2, 2012, 2016, 2019
Mac OS X® 10.6 to 10.10
Linux 3.5.x to 4.11.x LTS versions only
Special Notes / Requirements
System and Cable Requirements PCI Express enabled computer with an available PCI Express x1 slot or higher
Environmental
Humidity 80% RH
Operating Temperature -0°C to 75°C (32°F to 167°F)
Storage Temperature -40°C to 125°C (-40°F to 257°F)
Physical Characteristics
Product Height 2 cm [0.8 in]
Product Length 90 mm [3.5 in]
Product Width 80 mm [3.1 in]
Weight of Product 46 g [1.6 oz]
Packaging Information
Package Height 32 mm [1.3 in]
Package Length 14.4 cm [5.7 in]
Package Width 17.4 cm [6.9 in]
Shipping (Package) Weight 132 g [4.7 oz]
What's in the Box
Included in Package 1 - PCI Express USB 2.0 Card
1 - Full Profile Bracket
1 - Driver CD
1 - Instruction Manual

Compatibility

View full OS compatibility
Windows® 2000, XP, Vista, 7, 8, 8.1, 10
Windows Server® 2003, 2008 R2, 2012, 2016, 2019
Mac OS X® 10.6 to 10.10
Linux 3.5.x to 4.11.x LTS versions only

Certifications

Accessories